• You use an Adblocker to hide advertisements. This type of program makes it difficult to keep this website up and running, since displaying advertisements is the only way to pay for hosting. Would you like to make an exception for this site? We promise that you will not be bothered by the advertisements.
  • Get upgrade the account (anti-ads - Silver or Gold) ----> "Click".
  • Check out: DKS-Discord
  • Forum - DKS is an English speaking community. If you reply to a thread using non-English languages(French/Spanish/etc), staff will review your post and may delete it.

Echoes Checking Software

only1fuego

DKS Member
Jul 14, 2021
24
10
hmm I keep getting " Checking if software can be played" I just finished updating my switch & atmonsphere.. everything else is working fine .. could it be my SIGPATCHES are out of date?
 

Azrial

Midlife Gamer
Staff member
Forum Moderator
Dec 23, 2019
1,779
1,892
hmm I keep getting " Checking if software can be played" I just finished updating my switch & atmonsphere.. everything else is working fine .. could it be my SIGPATCHES are out of date?
Are you using the latest sigpatches? If you've updated Atmos and your Switch, you have to do your Sigpatches as well.
 

only1fuego

DKS Member
Jul 14, 2021
24
10
Are you using the latest sigpatches? If you've updated Atmos and your Switch, you have to do your Sigpatches as well.
Your probably right... I found a Sig patch file on the net but it looks like it wasn't the latest version ... ... Just odd that other new games like FFVII Crisis core work on the current SIG Patches
 

Sakamoto

Well-known Member
Helper
Dec 31, 2018
231
1,012
Your probably right... I found a Sig patch file on the net but it looks like it wasn't the latest version ... ... Just odd that other new games like FFVII Crisis core work on the current SIG Patches
African host latest sigpatches here: https://cfw.pw/sigpatches
Extract to root SDCard (make sure to click Yes for overwriting files and merging folders)
i have them installed on 2 switch 14.0.0 and 15.0.1
And Crisis core use old MasterKey 14 than Chained Echoes latest Mkey 15
 

only1fuego

DKS Member
Jul 14, 2021
24
10
African host latest sigpatches here: https://cfw.pw/sigpatches
Extract to root SDCard (make sure to click Yes for overwriting files and merging folders)
i have them installed on 2 switch 14.0.0 and 15.0.1
And Crisis core use old MasterKey 14 than Chained Echoes latest Mkey 15
Thank you, i just redownloaded the game, installed it again and it ended up working.

Thank you for the file .. ill keep it handy for the next switch i end up modding